Comment résoudre npm UNMET PEER DEPENDENCY?

Je suis sur Windows 10, Node version 5.6.0 et npm version 3.6.0. Essayer d’installer du matériel angular et mdi sur mon dossier de travail. npm install angular-material mdi me donne les messages d’erreur suivants:

+ – angular@1.5.0

+ – UNMET PEER DEPENDENCY angular-animate@^1.5.0

+ – UNMET PEER DEPENDENCY angular-aria@^1.5.0

+ – angular-material@1.0.6

+ – UNMET PEER DEPENDENCY angular-messages@^1.5.0 `- mdi@1.4.57

npm WARN enoent ENOENT: pas un tel fichier ou répertoire, ouvrez ‘C: \ Users \ xxxxx \ Desktop \ ngClassifieds \ package.json’

npm WARN angular-material@1.0.6 nécessite un homologue de angular-animate@^1.5.0 mais aucun n’a été installé.

npm WARN angular-material@1.0.6 nécessite un pair d’angular-aria@^1.5.0 mais aucun n’a été installé.

npm WARN angular-material@1.0.6 nécessite un pair d’angular-messages@^1.5.0 mais aucun n’a été installé.

Comment est-ce que je résous ceci pour obtenir le matériel angular et le mdi installé?

npm n’installe plus les dépendances des pairs, vous devez donc les installer manuellement, faites simplement une npm install sur les deps nécessaires, puis essayez de réinstaller le principal.


Répondre au commentaire:

c’est juste dans ce message, il dit quel deps vous manque

 UNMET PEER DEPENDENCY angular-animate@^1.5.0 +-- UNMET PEER DEPENDENCY angular-aria@^1.5.0 +-- angular-material@1.0.6 + UNMET PEER DEPENDENCY angular-messages@^1.5.0 `-- mdi@1.4.57` 

Donc, vous devez npm install angular angular-animate angular-aria angular-material angular-messages mdi

UNMET PEER DEPENDENCY erreur UNMET PEER DEPENDENCY est renvoyée lorsque les dépendances d’un ou plusieurs modules spécifiés dans le fichier package.json ne sont pas remplies. Vérifiez attentivement les avertissements et mettez à jour le fichier package.json avec les versions correctes des dépendances.

Puis courir

 rm -rf node_modules/ npm cache clean npm install 

Cela installera correctement toutes les dépendances requirejses.

Dans mon cas, toutes les dépendances étaient déjà là. Veuillez mettre à jour NPM dans ce cas car il pourrait avoir été planté. Cela a résolu mon problème. npm install -g npm

npm-install-peers a fonctionné pour moi.

 npm install -g npm-install-peers 

L’une des causes les plus possibles de cette erreur pourrait être que vous avez défini l’ancienne version dans votre package.json. Pour résoudre ce problème, modifiez les versions dans le package.json pour qu’elles correspondent à celles dont npm se plaint.

Une fois terminé, lancez npm install et le tour est joué !!.

Ok, j’ai lutté pendant longtemps pour essayer de comprendre cela. Voici l’option nucléaire , quand vous avez épuisé tous les autres moyens ..

  • Créez un nouveau dossier sur votre PC.
  • Télécharger une toute nouvelle installation d’angular – J’ai utilisé ce guide: https://coursetro.com/posts/code/55/How-to-Install-an-Angular-4-App
  • Exécutez-le, assurez-vous qu’il fonctionne
  • Ensuite, installez vos dépendances une par une à partir de votre fichier package.json
  • Exécutez-le après chaque installation

Lorsque vous avez terminé et que cela fonctionne toujours, importez votre code réel dans ce nouveau projet. Corrigez les erreurs de compilation dans la nouvelle version des causes angulars.

Thats ce qui l’a fait pour moi .. 1 heure de reprise vs 6 heures d’essayer de comprendre wtf était faux .. J’aimerais l’avoir fait de cette façon pour commencer ..

Aujourd’hui disponible Angular 2 rc.7 , et j’ai eu un problème similaire avec rxjs@5.0.0-beta.12 PEER rxjs@5.0.0-beta.12 .

Si vous, comme moi, remplacez simplement @angular/...rc.6 par @angular/...rc.7 – ce n’est pas suffisant. Parce que, par exemple, @angular/router n’a pas de version rc.6 .

Dans ce cas, mieux revoir package.json dans Quick start

La réponse donnée ne fonctionnera pas toujours. Si cela ne résout pas votre problème. Assurez-vous que vous utilisez également le symbole correct dans votre package.json . Ceci est très important pour corriger ce mal de tête. Par exemple:

 warning " > @angular/comstackr-cli@5.2.7" has incorrect peer dependency "typescript@>=2.4.2 <2.7". warning " > tsickle@0.25.6" has incorrect peer dependency "typescript@>=2.4.2 <2.6". 

Donc, mon texte typescript doit être compris entre 2.4.2 et 2.6, n'est-ce pas?

J'ai donc changé ma bibliothèque de typescript en utilisant "typescript": "^2.7" en utilisant "typescript": "^2.5" . Semble correct?

Faux.

Le ^ signifie que vous êtes d'accord avec npm en utilisant "typescript": "2.5" ou "2.6" ou "2.7" etc ...

Si vous voulez apprendre ce que le ^ et ~ signifie, voyez: Quelle est la différence entre tilde (~) et caret (^) dans package.json?

Aussi, vous devez vous assurer que le paquet existe. Peut-être qu'il n'y a pas de "typescript": "2.5.9" recherche les numéros de paquet. Pour être vraiment en sécurité, retirez simplement le ~ ou le ^ si vous ne voulez pas lire ce qu'ils signifient.

vous pouvez résoudre en installant les dépendances UNMET globalement.

exemple: npm install -g @ angular / common @ 4.4.6

installez chacun un par un. ça a fonctionné pour moi.