Erreur de démarrage de Tomcat à partir de NetBeans – “127.0.0.1 *” n’est pas reconnu en tant que commande interne ou externe

Google et Stackoverflow m’ont tous deux montré des problèmes similaires, mais cette erreur est légèrement différente car l’adresse IP est suffixée par un astérisque:

NetBeans 8.0.1 me donne l’erreur suivante lors de la tentative de démarrage de Tomcat.

“127.0.0.1 *” n’est pas reconnu comme une commande interne ou externe, un programme utilisable ou un fichier de commandes.

Tomcat 7.0.56 et Tomcat 8.0.14 sont tous deux installés, ils démarrent tous les deux à partir de la ligne de commande (un à la fois). Je les ai ajoutés à la liste des serveurs de NetBeans comme Tomcat 7 et Tomcat 8.

J’ai une application web “Hello World” que j’ai configurée:
Propriétés -> Exécuter -> Serveur: essayé à la fois Tomcat 7 et Tomcat 8
Les deux donnent la même erreur.

Si j’essaie de démarrer Tomcat en utilisant soit:
Services -> Serveurs -> Tomcat 7 -> Démarrer
Services -> Serveurs -> Tomcat 8 -> Démarrer
J’ai la même erreur que lorsque vous essayez de démarrer une application Web:

“127.0.0.1 *” n’est pas reconnu comme une commande interne ou externe, un programme utilisable ou un fichier de commandes.

Des idées ?
Même si ce n’est que ce que l’astérisque fait là-bas?

En supposant que vous êtes sous Windows (ce bogue est causé par l’échappement de fichiers de chauve-souris), c’est un bogue introduit dans les dernières versions ( 7.0.56 et 8.0.14 ) pour contourner un autre bogue. Essayez de supprimer le " autour de la déclaration JAVA_OPTS dans catalina.bat . Il a été corrigé pour moi avec Tomcat 7.0.56 hier.

Dans 7.0.56 dans bin/catalina.bat:179 et 184

 :noJuliConfig set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%" .. :noJuliManager set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%" 

à

 :noJuliConfig set JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG% .. :noJuliManager set JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER% 

Pour votre astérisque, il se peut que votre configuration se limite à celle de votre hôte.

Je l’ai vu sur le bugtracker de Tomcat hier, mais je ne trouve plus le lien. Modifier le trouvé https://issues.apache.org/bugzilla/show_bug.cgi?id=56895

J’espère que cela corrige votre problème.

Après avoir suivi les étapes de @Johnride, j’ai toujours eu la même erreur.

Cela a résolu le problème:

Outils-> Options-> Ne sélectionnez aucun proxy

source: https://www.youtube.com/watch?v=uI1j-8F8eN4

Outils-> Options-> Sélectionnez aucun proxy est travaillé pour moi