VS2010 et IE10 L’attachement du débogueur de script pour traiter iexplore.exe a échoué

J’utilise donc Win7 x64 avec VS2010 et j’ai installé IE10 Win7 Preview et ReSharper 6.1.

Lorsque je tente de démarrer le débogage, je reçois les éléments suivants:

Msgstr “” “Echec de la connexion du débogueur Script à traiter [1111] iexplore.exe” sur la machine “MINE”. Un débogueur est déjà connecté. ”

Je peux cliquer sur OK et regarder les sessions de débogage attachées – [1111] est grisé et il existe une autre instance de iexplore.exe avec le titre de ma solution. Je peux attacher manuellement et cela fonctionne très bien.

Je pensais que peut-être, car il y avait deux pids iexplore.exe il y aurait quelque chose de mal, il n’y a pas deux tabs ou des fenêtres ouvertes et j’ai désactivé la récupération automatique en cas de panne.

J’ai essayé ceci: L’ attachement du débogueur de script à traiter ‘[XXXX] IEXPLORE.EXE’ sur la machine ‘NOM’ a échoué

N’a pas fonctionné.

Des idées?

    Il existe un correctif plus simple pour le problème de débogage JavaScript dans IE10:

    1. Fermer IE
    2. Dans l’invite cmd élevée, exécutez cette commande:

      regsvr32.exe "%ProgramFiles(x86)%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll" 

    (ou %ProgramFiles% sur un système d’exploitation 32 bits)

    La mise à niveau IE10 réinitialise tout un tas de choses. J’ai suivi 2 étapes pour résoudre ce problème.

    1. Dans les parameters avancés d’IE, sous la navigation, décochez la case “Désactiver le débogage de script (Internet Explorer)”.
    2. L’exécution de cette invite de commande (avec les droits d’administrateur): –

      regsvr32.exe “% ProgramFiles (x86)% \ Fichiers communs \ Microsoft Shared \ VS7Debug \ msdbg2.dll

    La combinaison de ces 2 et un redémarrage du navigateur bien sûr l’ont corrigé.

    Je suis également d’accord, la solution marquée ci-dessus de la désinstallation n’est guère une solution appropriée.

    J’ai exactement le même problème. J’ai trouvé une solution temporaire mais je dois exécuter chaque fois la même séquence comme suit.

    1. Cliquez sur le menu “Debug”
    2. Cliquez sur le menu “Fenêtre”
    3. Cliquez sur le menu “Processus”
    4. Et faites un clic droit sur iexplorer.exe et “détachez le processus”

    Le problème est que chaque fois que je dois répéter cette procédure, chaque compilation de mon projet …

    J’avais le même problème avec VS2010 et IE10 (Win7). Après des semaines à essayer de résoudre ce problème, j’ai finalement décidé de lancer VS2012 pour déboguer mon site. J’ai également mis à jour VS2012 à SP1 et redémarré ma machine et maintenant le débogage VS2010 fonctionne bien dans IE10.

    Essayez donc d’installer VS2012 SP1 pour résoudre les problèmes de compatibilité avec VS2010 et IE10.

    Quelqu’un a suggéré que l’exécution de cette commande dans une invite de commande élevée ferait l’affaire:

     regsvr32.exe "%ProgramFiles(x86)%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll" 

    Je l’ai essayé et il a signalé que la DLL n’était pas trouvée. J’ai cherché le msdbg2.dll et il n’a pas été trouvé. C’est apparemment caché.

    Iran:

     regsvr32.exe "C:\Program Files (x86)\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll" 

    et ça a fonctionné.

    C’était sur Windows 7, 64 bits, VS2010 Premium

    J’ai eu le même problème avec VS2010 et VS2012 sur WIN7 + IE10 CTP en décembre dernier. J’espérais que ce problème était résolu dans la version RTM d’IE10, aujourd’hui j’ai découvert que ce n’était pas le cas.

    J’ai essayé toutes les solutions dans cet article, même en installant la mise à jour 2 CTP 4 de VS2012, mais rien n’a résolu le problème.

    J’ai décidé de revenir à IE9. Je n’ai pas utilisé les étapes correctes décrites dans la réponse de MonteChristo.

    J’ai désinstallé IE10 en faisant:

    1. Win + R
    2. appwiz.cpl
    3. Activer ou désactiver des fonctionnalités Windows.
    4. Décochez Internet Explorer 10
    5. Redémarrer

    Maintenant, cela ne revient pas à IE9. Est simplement supprime IE10. Pas ce que je voulais. J’ai donc installé IE10 à nouveau en suivant les mêmes étapes que ci-dessus.

    Après cela, je ne pouvais pas m’en empêcher de le tester une fois de plus et cela a fonctionné de manière surprenante. Ce que j’ai remarqué est le suivant. Avant de désinstaller IE10, exécutez / parcourez avec Internet Explorer (voir image ci-dessous) deux fois.

    Après la désinstallation, l’installation d’IE10 est répertoriée une seule fois. Je ne sais pas si c’est lié mais je voulais le mentionner.

    entrer la description de l'image ici

    Essayez de réinitialiser vos parameters IE, puis décochez la case “Désactiver le débogueur de scripts (Internet Explorer)” sous Outils-> Options Internet-> Avancé et réinitialisez votre ordinateur.

    Même avec IE10 récemment sorti pour Win 7, le problème persistait. Cependant, vous avez compris que l’installation de VS2012 SP1 avait résolu ce problème, alors j’ai installé Visual Studio 2012 Express via Web Platform Installer (v4.5) – ce qui semble être corrigé!

    J’ai VS2010 & 12 et IE10 , Win 7 x64 .

    J’ai essayé tout ce qui précède (sauf rétrograder à IE9 , évidemment) en vain.

    J’ai eu l’intuition que VS2012 Update 2 pourrait résoudre le problème, et j’avais raison.

    Pas de cmd , pas de réinstallation, pas de redémarrage. Il a corrigé pour VS2010 & 12 .

    J’espère que ça aide aussi quelqu’un d’autre.

    J’ai VS2010 et VS2012 sur le PC. C’était un projet ASP.NET et cela ne fonctionnait pas pour le débogage JS. J’ai essayé les deux résultats de la version était la même. Tout ce que j’ai fait était un succès:

    1. regsvr32.exe "%ProgramFiles(x86)%\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll"n’a pas aidé
    2. Case cochée / décochée “Silverlight” dans la page de propriétés – no
    3. Rétrogradation d’IE 10 -> IE 9 -> IE 8 – pas de chance
    4. Repair VS 2010 – ne fonctionne pas pour moi
    5. Dans IE “Paramètres avancés” décochez “Désactiver le débogage de script (Internet Explorer)” et “Désactiver le débogage de script (Autre)” – no

    Enfin, j’ai installé “Remote Tools pour Visual Studio 2012 Update” et “VS2012 Update 4”. Je ne suis pas sûr de ce qui est résolu, mais ça a disparu. Et VS2010 et VS2012 ont commencé à déboguer JavaScript. Par conséquent, il semble que certains composants ont été corrompus. Aujourd’hui, je pense que le meilleur choix pour résoudre ce problème devrait être ré-installer IE, je veux dire rétrograder et installer à nouveau, plus loin, vous pouvez installer la mise à jour 4 pour VS2012.

    Notez s’il vous plaît:

    “Dans la fenêtre de la page de propriétés, la case à cocher” Silverlight “doit être décochée”

    J’ai eu un problème similaire (en utilisant VS2012 RC) après avoir mis à jour IE9 vers IE10 – Je l’ai réparé en réparant l’installation de VS2012 – Je suis arrivé avec un doublon Internet Explorer suspecté dans la liste Je n’ai pas pu trouver les symboles chargés.

    Dans VS2010, bien sûr, il n’y a pas cette liste déroulante, mais essayer de réparer pourrait être une solution.

    J’ai eu le même problème depuis la mise à jour vers IE 10 sur une machine Win 7 Pro exécutant VS 2010 SP1.

    J’ai essayé de nombreuses suggestions, mais aucune n’a fonctionné. Je l’ai finalement corrigé en rétrogradant à IE 9, à savoir:

    1. Tapez “appwiz.cpl” dans le Win 7 Search Box sous l’orbe de démarrage et appuyez sur.
    2. Cliquez sur “Afficher les mises à jour installées”
    3. Rechercher “Internet Explorer 10”
    4. Cliquez avec le bouton droit sur “Internet Explorer 10” et sélectionnez “Désinstaller”
    5. Redémarrez.

    Le débogage fonctionne à nouveau.