“Remote System Explorer Operation” provoquant un gel pendant quelques secondes

J’observe “Fonctionnement de l’Explorateur de systèmes distants” dans la vue Progrès d’Eclipse après chaque sauvegarde du fichier Java (il peut donc être lié à la compilation?). Cela rend l’Eclipse inutilisable pendant 1 à 10 secondes. Dans certains projets (à peu près de la même taille), c’est plus rapide, dans d’autres, plus lent.

Je ne sais pas quel plugin pourrait en être la cause. J’ai l’ Build id: 20090920-1017 . J’ai quelques plugins installés .

J’ai essayé de faire en sorte que tous les systèmes distants soient enabled=false sous Préférences | Systèmes distants (peu importe ce que cela signifie). Je n’ai pas aidé.

Une idée de comment le résoudre?

MODIFIER:

  1. Cela n’arrive pas quand Project | Build automatically Project | Build automatically est désactivé. C’est donc une partie du processus de construction.

Allez sur MAC:

 Eclipse -> Preferences -> General -> Startup and Shutdown. 

– Décocher l’interface utilisateur RSE.

 Eclipse -> Preferences -> Remote Systems. 

-Désélectionnez Rouvrir la vue Systèmes distants à l’état précédent.

Mettez à jour votre Eclipse à 4.3.1 (au moins) en raison d’un bogue sur la version précédente.

Redémarrez Eclipse et c’est fait.

Cela me rendait fou aussi.

Grâce à ce sujet, j’ai compris que c’était le plug-in RSE , mais je ne pouvais pas non plus désinstaller le plug-in Remote System Explorer . J’ai dû supprimer tous les plugins dont le nom a été lancé par org.eclipse.rse dans plugins/ , ça marche maintenant.

Accédez aux préférences et supprimez le projet ‘RemoteSystemsTempFiles’; Chemin d’access: Windows -> préférences -> espace de travail -> ordre de fabrication, décochez la case “utiliser l’ordre de construction par défaut”, supprimez le projet, appliquez. Peut-être que votre question sera résolue.

Fermez la vue Git-Staging!

J’ai eu le même problème sur mon Eclipse 4.3 Kepler. Après avoir retiré (fermant) la vue Git-Staging, le problème a été résolu!

J’ai aussi ce problème.

J’ai constaté que l’opération fait partie du plug-in Remote System Explorer fourni avec SpringSource 3.3 (Kepler) . Essayer de trouver comment le désinstaller maintenant. Je posterai ici une fois que je le trouverai.

Des informations sur la procédure d’installation peuvent être trouvées ici (étape 3): http://www.pasortingckjwaters.com/blog/2011-07-24/how-setup-eclipse-php-pdt-remote-system-explorer-theme- plugins de gestion et drupal / 35

En ce qui concerne la désinstallation, j’essaie toujours (l’option de désinstallation est grisée pour moi dans le panneau des détails de l’installation).

J’ai essayé Windows > Preferences > Remote Systems , définissant tout sur false, mais le problème persiste.

Solution
Nous avons depuis déménagé dans une installation Vanilla d’Eclipse Kepler et nous avons simplement ajouté les plug-ins dont nous avons besoin (à l’exception de Remote System Explorer). Cela a résolu le problème.

J’ai expérimenté des tâches “Remote System Explorer Operation” en cours d’exécution sur une sauvegarde de ressources.

Kepler + AspectJ + SpringSource Dans mon cas, cela était dû à des définitions de pointcut non valides. J’ai eu 30 points de repère et 4 d’entre eux ont fait référence à une classe supprimée. J’ai remarqué des marqueurs AOP de spring clignotants.

Après avoir corrigé les points, le gel s’est arrêté.

Je pense que j’ai peut-être trouvé un moyen de contourner ce problème …

  1. Si la fenêtre apparaît, fermez-la puis cliquez sur le bouton Stop en bas
  2. Désélectionnez “Générer automatiquement” sous Projet
  3. Projet | Projet de construction
  4. Cochez “Générer automatiquement”

Maintenant, essayez à nouveau ce que vous faisiez.

Window -> Show View -> Other... -> Remote System Details (or maybe Remote Systems)

Ceci est avec Eclipse 4.3 Kepler (2013/2014)

Recherchez tous les éléments non-locaux et supprimez-les. Je ne pouvais pas voir de fonction DISABLE.

Pour moi, cela semble arrêter le délai supplémentaire de 1 à 3 secondes (sur la boîte Intel i7) lorsque vous enregistrez avec l’éditeur et qu’une auto-construction se termine.

http://forum.spring.io/forum/spring-projects/springsource-tool-suite/128402-sts-3-3-0-m2-and-remote-system-explorer-poor-performances suggère que STS 3.4M1 + pourrait atténuer les problèmes, je n’ai pas encore essayé cela car je ne fais que lancer les versions de GA, donc j’essaierai quand Kepler SR1 sortira d’ici 7 jours.

Pour moi en ce moment pour Spring Tool Suite 3.9.4. Relâchez la désactivation du système distant via le menu de préférences a résolu le problème. Voici la référence qui m’a aidé. mais après un certain temps, le problème est de nouveau là!

Passé à l’éclipse photon une semaine, ne voyait plus le “système distant …” ennuyant.

J’ai également été confronté à plusieurs opérations d’exploration de systèmes à distance lors de la compilation d’un projet C ++ dans eclipse (j’utilise la plate-forme basée sur Nsight bu nvidia-eclipse). Après avoir fait toutes les solutions suggérées ici, j’avais toujours le problème.

MAIS – lorsque j’ai modifié l’option -w pour l’option -w pour le compilateur gcc, le problème a disparu.

GO TO – Propriétés du projet -> Build-> Settings -> Onglet Paramètres de l’outil-> Compilateur gcc -> Avertissements -> Décochez -Wall et cochez -w

La même chose vaut pour G ++ Comstackr.

J’ai également rencontré des tâches ” Remote System Explorer Operation ” en cours d’exécution sur une sauvegarde de ressources.

Lors de l’utilisation de la méthode AspectJ Around Dans mon cas, cela a été causé par Aspectj autour de la méthode de création de marqueurs AOP Spring.

Supprimer les AspectJ Les marqueurs du problème de blocage du système de console des Eclipse Markers seront résolus automatiquement.

Le problème a disparu après une mise à jour des bibliothèques Eclipse (utilisant toujours la même version). Je suppose donc que la solution consiste à effectuer une mise à jour.