Comment mettre à jour Angular CLI vers la dernière version

En utilisant ng --version j’ai eu:

@ angular / cli: 1.0.0

qui n’est pas la dernière version disponible.

Comme j’ai une interface de ligne de commande angular installée globalement sur mon système, pour la mettre à niveau, j’ai essayé:

npm update angular-cli -g

Mais cela ne fonctionne pas, car il rest à la version 1.0.0.

Après avoir lu certains problèmes signalés dans le référentiel GitHub, j’ai trouvé la solution.

Pour mettre à jour le paquetage angular-cli installé globalement dans votre système, vous devez exécuter:

 npm uninstall -g angular-cli npm cache clean or npm cache verify (if npm > 5) npm install -g @angular/cli@latest 

Selon votre système, vous pouvez avoir besoin de préfixer les commandes ci-dessus avec sudo .

De plus, il est fort probable que vous souhaitiez également mettre à jour votre version de projet locale, car dans votre répertoire de projet, elle sera sélectionnée avec une priorité plus élevée que celle du projet global:

 rm -rf node_modules npm uninstall --save-dev angular-cli npm install --save-dev @angular/cli@latest npm install 

Merci grizzm0 de l’ avoir signalé sur GitHub .

Après la mise à jour de votre interface de ligne de commande, vous souhaiterez probablement mettre à jour votre version angular également.

Remarque : si vous effectuez une mise à jour vers Angular CLI 6+ à partir d’une version antérieure, vous devrez peut-être lire ceci .

N’oubliez pas de mettre à jour vos paquets principaux après la mise à jour de Cli.

ng6 + (Cli 6.0+) : caractéristiques des commandes simplifiées

Tout d’abord, mettez à jour votre Cli

 npm install -g @angular/cli npm install @angular/cli ng update @angular/cli 

Ensuite, mettez à jour vos packages principaux

 ng update @angular/core 

Si vous utilisez RxJS, exécutez

 ng update rxjs 

Il mettra à jour RxJS à la version 6 et installera le rxjs-compat sous le capot.

Si vous rencontrez des erreurs de construction, essayez une installation manuelle de:

 npm i rxjs-compat npm i @angular-devkit/build-angular 

Enfin, vérifiez votre version

 ng -v 

Note sur la production:

ng6 n’utilise plus intl dans polyfills.ts

 //remove them to avoid errors import 'intl'; import 'intl/locale-data/jsonp/en'; 

ng5 + (Cli 1.5+)

 npm install @angular/{animations,common,comstackr,comstackr-cli,core,forms,http,platform-browser,platform-browser-dynamic,platform-server,router}@next typescript@2.4.2 rxjs@'^5.5.2' npm install typescript@2.4.2 --save-exact 

Remarque:

  1. La version de Typescript prise en charge pour Cli 1.6 au moment de l’écriture est la version 2.5.3.
  2. L’utilisation de @next met à jour le package en version bêta, le cas échéant. Utilisez @latest pour obtenir la dernière version non bêta.

Après avoir mis à jour le package global et le package local, effacez le cache pour éviter les erreurs:

 npm cache verify (recommended) npm cache clean (for older npm versions) 

Voici les références officielles:

  1. Mise à jour du Cli
  2. Mise à jour du package principal des packages principaux .

vous pouvez simplement utiliser

npm install -g angular-cli – si c’est votre première fois

npm install -g @angular/cli@latest – si vous êtes déjà installé, donc pour la mise à jour

La commande puissante installe et remplace le dernier package.

J’avais un problème similaire. Je l’ai corrigé.

  npm install -g @angular/cli@latest 

et

 npm install --save-dev @angular/cli@latest 

entrer la description de l'image ici

Cette commande fonctionne bien:

 npm upgrade -g @angular/cli 

En plus de @ShinDarth, répondez .

J’ai fait ce qu’il a dit, mais mon paquet n’a pas mis à jour la version angular, et je sais que ce post concerne le angular-cli , mais je pense que cela peut aussi aider.

  • donc après avoir fait ce que @ShinDarth a dit ci-dessus, pour réparer ma version angular, j’ai dû créer un nouveau projet avec -ng new projectname qui a généré un paquet.
  • copiez le nouveau paquet, puis collez le nouveau paquet sur tous les paquets de projets nécessitant une mise à jour (n’oubliez pas d’append les dépendances que vous aviez et de changer le nom sur la première ligne) ou modifiez simplement les versions sans copier-coller.
  • puis lancez -npm install .

Maintenant que mon ng serve fonctionne à nouveau, peut-être y a-t-il une meilleure façon de faire tout cela, si quelqu’un le sait, s’il vous plaît partagez, parce que c’est difficile à faire avec tous les projets nécessitant une mise à jour.

Pour mettre à jour Angular CLI vers une nouvelle version, vous devez mettre à jour le package global et le package local de votre projet.

Paquet global:

 npm uninstall -g @angular/cli npm cache clean # if npm version is > 5 then use `npm cache verify` to avoid errors (or to avoid using --force) npm install -g @angular/cli@latest 

Package de projet local:

 rm -rf node_modules dist # use rmdir /S/Q node_modules dist in Windows Command Prompt; use rm -r -fo node_modules,dist in Windows PowerShell npm install --save-dev @angular/cli@latest npm install 

Source: Github

L’approche suivante a fonctionné pour moi:

 npm uninstall -g @angular/cli 

puis

 npm cache verify 

puis

 npm install -g @angular/cli@latest 

Je travaille sur Windows 10, parfois je devais utiliser: npm cache clean --force aussi. Vous n’avez pas besoin de faire si vous n’avez aucun problème lors de l’installation.

Tout ce que vous avez à faire est de modifier avec angular-cli-diff et d’appliquer les modifications dans votre projet actuel.

Voici les étapes:

  1. Disons que vous allez de 1.4. à 1.5 alors vous faites https://github.com/cexbrayat/angular-cli-diff/compare/1.4.0…1.5.0
  2. cliquez sur l’onglet File changed
  3. Appliquez les modifications à votre projet en cours.
  4. npm install / yarn
  5. Testez tous les npm scripts ( plus de détails ici: https://stackoverflow.com/a/45431592/415078 )

Dans mon cas, j’ai installé angular-cli localement en utilisant npm install –save-dev angular-cli. Ainsi, lorsque j’utilise la commande npm install -g @ angular / cli, cela génère une erreur indiquant que “votre version globale de la CLI angular (1.7.3) est supérieure à votre version locale (1.4.9)” . S’il vous plaît noter que les angles angulars, @ angular / cli et @ angular / cli @ dernier sont deux cli différents. Ce qui résout ce problème est de désinstaller tous les cli, puis d’installer les derniers cli angulars à l’aide de npm install -g @ angular / cli @ latest