Xcode 5 – “L’application n’a pas réussi à installer le simulateur iOS” chaque fois que je change de simulateur

En utilisant Xcode 5 GM, chaque fois que je passe aux simulateurs 5.1, 6.0 ou 6.1 pour tester, j’obtiens l’erreur “iOS Simulator n’a pas réussi à installer l’application”. Lorsque je réinitialise le simulateur, cela fonctionne, mais cela devient très fatiguant.

Quelqu’un at-il un correctif permanent ou une solution de contournement?

    On dirait que c’est un problème connu. A partir des notes de version de Xcode 5 :

    Après avoir basculé la cible de déploiement minimale d’une application depuis iOS 7.0 vers une version antérieure à iOS 7.0, la création et l’exécution de l’application peuvent échouer avec le message «iOS Simulator n’a pas pu installer l’application».

    • Allez sur l’écran d’accueil iOS, cliquez sur l’icône de l’application et maintenez-la enfoncée, puis appuyez sur le bouton «X» pour supprimer l’application. 13917023

    Une autre note de publication:

    Simulateur iOS

    • Si une application iOS est détachée, le redémarrage de la même application à partir de Xcode entraînera un écran noir dans le simulateur, même si la nouvelle application est lancée. Terminez l’application dans le simulateur ou relancez-la pour la deuxième fois. 14648784

    Supprimez l’ancienne version de l’application dans votre simulateur (généralement iOS 6.x).

    Alternativement, en-tête sur iOS Simulator – Réinitialiser le contenu et les parameters.

    Cela peut être plus facile lorsque vous avez beaucoup d’applications sur le simulateur et que vous ne vous souvenez plus de celui sur lequel vous travaillez actuellement.

    Vous devez le faire pour chaque version du simulateur iOS à l’origine du problème.

    Aucune des autres suggestions n’a fonctionné pour moi. Cependant, après avoir comparé mes parameters d’application existants à un nouveau projet vanilla, j’ai remarqué que le champ “Générer” de ma cible était vide. Une fois que j’ai mis quelque chose dans ce champ, l’application est installée correctement!

    si vous avez déjà développé un projet et que vous avez utilisé xib pour développer des vues,

    X-Code> Barre de sélection de l’inspecteur> Document du générateur d’interface> s’ouvre dans> et passe de Xcode Default (5.o) à Xcode 4.6.
    entrer la description de l'image ici
    Construire et exécuter votre application, elle fonctionnera correctement, si elle ne sera pas exécutée à nouveau, en-tête sur iOS Simulator – Réinitialiser le contenu et les parameters. supprimer l’ancienne application du simulateur puis exécuter à nouveau.

    J’ai eu le même problème mais résolu par la voie suivante ….

    1. Lancer le simulateur iOS

    2. Allez et cliquez sur “iOS Simulator” menu

    3. Cliquez sur “Réinitialiser le contenu et les parameters”

    4. Fermez le simulateur et reconstruisez votre application.

    entrer la description de l'image ici

    La capture d’écran ci-dessus montre comment vous pouvez le faire …

    Je pense que cela fonctionne pour vous … !!!

    La suppression de l’application dans le simulateur fonctionne pour moi. je voulais juste append que cela ne se produit que si j’ouvre xib créé dans xcode 4.6 Si ce sont d’autres fichiers, cela n’arrivera pas

    essaye ça ….

    Dans mon cas, rien n’a fonctionné pour moi, après avoir réinitialisé le simulateur de contenu, je ne suis pas en mesure d’installer l’application sur le simulateur. Après cela, je viens de changer l’emplacement de mon projet. Je viens de déplacer le projet à un autre endroit. alors il s’est installé avec succès.

    Aucune des choses ci-dessus n’a fonctionné pour moi. Je viens de réinstaller xcode et cela a fonctionné.

    Ran dans ce problème aujourd’hui. Trouvé que c’était un dossier de référence vide (dossier bleu) à l’origine de cela. Supprimé le dossier de Resources in Build Phase … nettoyé le dossier de compilation de celui-ci, et il a disparu.

    / Users / YOURUSERNAME / Library / Developer / Xcode / -> Supprimez tout le contenu de ce dossier, puis lancez simplement l’application depuis Xcode.

    Pour vérifier votre fichier Executable, enregistrez ex. $ (EXECUTABLE_NAME) (paramètre de projet – page de propriétés info)

    J’ai un problème différent lorsque le message d’erreur «iOS Simulator n’a pas réussi à installer l’application», car j’ai ajouté une propriété dans App-Info.plist sans aucune valeur. Par exemple, [Catégorie d’application] sans valeur. Ainsi, l’erreur apparaîtra également.

    Lorsque j’ai eu cette erreur, l’image du téléphone est apparue, mais l’image de l’application que je voulais tester ne l’était pas. Au lieu de cela, j’étais sur la page principale du téléphone qui affiche les applications que vous avez. J’ai résolu ce problème en supprimant les nombreuses icons apparaissant sur les écrans de démarrage, soit environ 30 d’entre elles. Celles-ci avaient été créées lorsque je testais des applications au fil des mois. Donc, ne pas dire que c’est une solution, mais il a commencé à fonctionner après avoir supprimé les anciennes images de l’application.

    Pour moi, il s’agissait de -framework XCTest .

    L’application a iOS Simulator failed to install application avec iOS Simulator failed to install application

    et sur le périphérique Could not inspect the application package.

    Supprimé et fonctionne maintenant.

    Vous utilisez Xcode GM qui est en phase bêta. Utilisez la dernière version de Xcode 5.1.1 disponible. En outre, ces erreurs se produisent lors de la commutation entre le simulateur (32 bits et 64 bits).

    1. Quittez le simulateur et reconstruisez l’application. OU
    2. Réinitialiser le simulateur à partir de “Simulateur iOS” -> “Réinitialiser le contenu et les parameters ..”

    Erreur

    J’ai changé le nom de mon application et l’identifiant de l’ensemble à mi-chemin. J’ai supprimé le nom du fichier exécutable dans mon plist. Je suis revenu à “$ {EXECUTABLE_NAME}” (pas de guillemets) et je suis de retour en affaires.