Le profil d’approvisionnement Xcode 8 ne se télécharge pas

J’ai récemment mis à jour vers Xcode 8 et lorsque je clique sur l’option “télécharger” à côté du profil d’approvisionnement dans le menu Xcode / Preferences / Accounts / View Details, il devient gris et ne se télécharge pas. Après avoir redémarré Xcode, le bouton de téléchargement est à nouveau cliquable et le problème persiste. Le téléchargement manuel du profil d’approvisionnement et la suppression sur l’icône Xcode n’ajoutent pas le profil à un compte de développeur spécifique dans Xcode 8. Quelqu’un a-t-il eu ce problème récemment et l’a résolu? J’ai vérifié toutes les questions liées à la nouvelle version de Xcode, toujours pas de solution.

Je vois le même problème où le bouton de téléchargement est grisé mais le téléchargement ne semble jamais se terminer.

J’ai supprimé manuellement tous les profils dans finder et cliqué sur le téléchargement. Même si le téléchargement ne semble pas terminé, le profil est toujours téléchargé …

Vous pouvez consulter vos profils dans finder à

HOME/Library/MobileDevice/Provisioning Profiles 

entrer la description de l'image ici

Notez que cette interface utilisateur dans Xcode est pratique et ne devrait pas bloquer votre travail. Les profils que vous souhaitez télécharger sont toujours disponibles en procédant comme suit:

  1. Visitez developer.apple.com dans Safari
  2. Cliquez sur Compte et connectez-vous
  3. Cliquez sur Ceritficates, Identifiers et Profiles
  4. Accédez au profil qui vous intéresse et téléchargez-le
  5. Faites glisser le profil téléchargé sur l’icône de Xcode dans le dock.

À ce stade, votre profil sera installé sur votre Mac et utilisable dans Xcode.

Pour l’OP – si l’installation manuelle du profil de cette manière n’a pas résolu le problème, vous rencontrez probablement un autre problème de configuration ou un bogue. Pourriez-vous clarifier ce que vous avez vu après avoir installé manuellement le profil et l’avoir sélectionné dans l’onglet Général? Avez-vous reçu une erreur de génération ou un autre problème?

Je l’ai contourné en décochant et en revérifiant:

Paramètres du projet -> Général -> Signature -> «Gérer automatiquement la signature»

En cas de problème, le problème a commencé à apparaître après avoir ajouté la fonctionnalité Push (j’ai coché le bouton de basculement des notifications push dans target-> capacités).

J’avais le même problème. Voici ce que j’ai fait qui a résolu le problème pour moi.

  • J’ai d’abord cliqué avec le bouton droit sur chacun des deux profils qui seraient “gris-non-téléchargeables” et déplacés vers la corbeille.
  • Ensuite, j’ai supprimé le compte de développeur dans Xcode.
  • J’ai rajouté le compte développeur, je suis revenu aux détails et je les ai tous téléchargés.

Cela a fonctionné pour moi, j’espère que cela aide.

La réponse est ici.

Cela ne sonne pas beaucoup mais ça a vraiment fonctionné pour moi.

Cliquez avec le bouton droit sur le profil de provision et cliquez sur Afficher dans le Finder. Supprimez ensuite tout le profil de provision dans le dossier entier.

Pas de parameters de projet Xcode et cochez la case, Signature automatique du gestionnaire. Le xcode fera le rest pour vous.

J’ai aussi eu ce problème et j’ai réussi à renommer le profil. Par exemple, il s’appelait auparavant “[Nom de l’application] Dev”, et peu importe ce que je faisais, renouveler, supprimer et recréer avec le même nom, en l’installant manuellement, cela ne fonctionnerait pas du tout. Jusqu’à ce que je renomme le profil en “[Nom de l’application] Développement”.

Pour moi, cela m’a aidé à importer un profil dans XCode dans les parameters généraux: Importer un profil dans XCode

Essayez de supprimer et d’append votre compte si cela ne fonctionne pas

essayer

Terminal ouvert

Tapez defaults delete com.apple.Xcode et appuyez sur “Entrée”. Cela supprime les parameters personnalisés configurés.

Tapez rm -rf ~/Library/Application\ Support/Xcode et appuyez sur “Entrée”. Cela supprime également les dossiers de configuration.

Cela a sauvé ma journée si le problème persiste à nouveau réinstaller Xcode

J’ai rencontré le même problème et rien ne l’a résolu, alors j’ai trouvé un travail autour

  1. Téléchargez le profil d’approvisionnement directement à partir du compte de développeur et appuyez deux fois dessus, il sera installé dans xcode.
  2. Téléchargez et installez l’utilitaire de configuration iPhone.
  3. Ouvrez l’utilitaire de configuration iPhone, vous y trouverez tous les profils d’approvisionnement
  4. Sélectionnez ensuite le profil d’approvisionnement que vous souhaitez utiliser, puis le détail du profil que vous pouvez voir Identifiant du profil.
  5. Copiez cet identifiant de profil et ouvrez xcode.
  6. Accédez à l’identité de signature du code et sélectionnez-en d’autres dans le profil de configuration et collez l’identificateur de profil copié.
  7. Bingo!

Dans mon cas (Xamarin.iOS btw), j’ai supprimé manuellement tous les profils d’approvisionnement situés dans HOME/Library/MobileDevice/Provisioning Profiles mais je devais faire autre chose pour pouvoir déployer l’application sur un périphérique:

Le problème était que j’avais implémenté la toute nouvelle infrastructure de notifications push iOS 10, qui nécessite l’ajout de la propriété suivante à Entitlements.plist:

 aps-environment development 

Et j’essayais de déployer une version de développement en utilisant la production valeur plutôt que le development . Changer cette valeur a fait l’affaire.

En fait, toutes les solutions fournies peuvent fonctionner ou non, cela dépend de votre chance, mais vous devez surtout supprimer le compte, nettoyer les profils de provision comme la réponse “mogile_oli” et les rappend, mais aussi , n’oubliez pas pour réinitialiser les identités de signature:

Comptes -> Sélectionner le compte ajouté -> Sélectionner l’équipe et afficher les détails (ou double-cliquez sur le nom de l’équipe) – vous verrez le bouton Réinitialiser si nécessaire, cliquez dessus,

Et vous devez vraiment essayer de construire avec Automatic Signing d’abord, puis le supprimer, il semble impossible de le télécharger avec le bouton, pour l’instant, ignorez simplement le bouton de téléchargement de cette page, mais mieux vaut utiliser les dialogs pendant que vous essayez de construire.

Et quittez toujours Xcode et ré-ouvrez-le après presque chaque action que vous faites. Après avoir gaspillé comme 2 jours, je l’ai fait fonctionner comme ceci!

J’ai eu le même problème. Je laisse la solution qui a fonctionné pour moi:

J’ai supprimé tous les certificates expirés de mon keyChain, j’ai remarqué que les nouveaux certificates n’étaient pas téléchargés car j’avais un certificate expiré lié. Je ne sais pas pourquoi cela semble être un problème de ma cléChain / iTunes

Je l’ai résolu en créant mon propre certificate de développement (In Xcode) et en l’atsortingbuant dans le profil de provisioning de développement. Après l’avoir téléchargé et double-cliqué, j’ai pu le faire fonctionner correctement.