Xcode 5 – Plug-in requirejs non présent dans DVTPlugInCompatibilityUUIDs?

Après la mise à niveau de Xcode vers la v5.0.1, j’ai commencé à recevoir les avertissements suivants dans le terminal lorsque je tentais d’exécuter les commandes git dans le dossier du projet:

[MT] PluginLoading: compatibilité de plug-in requirejse UUID 37B30044-3B14-46BA-ABAA-F01000C27B63 pour le plug-in sur le chemin ‘~ / Library / Application Support / Développeur / Shared / Xcode / Plug-ins / Unity4XC.xcplugin’ absent dans DVTPlugInCompatibilityUUIDs

Je ne reçois aucun avertissement dans Xcode et le projet comstack très bien, mais il doit y avoir une raison. Des idées pourquoi cela se passe-t-il et comment y remédier?

J’ai modifié un shell commandes que j’ai trouvé ici pour résoudre ce problème pour tous mes plugins.

Pour résoudre ce problème:

 XCODEUUID=`defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID` for f in ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/*; do defaults write "$f/Contents/Info" DVTPlugInCompatibilityUUIDs -array-add $XCODEUUID; done 

Essayez de faire: xcode-select --install . Il a résolu mon problème

Dans mon cas de Xcode 7, supprimez tous les plugins Xcode corrigés.

 rm -rf ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/* 

Je crois que le problème est que vous avez un plug-in Xcode installé avec une paire clé-valeur DVTPlugInCompatibilityUUIDs manquante (ou incorrecte) dans son fichier plist. Voir ce que ce plugin a fait pour le résoudre: https://github.com/gfontenot/XVim/commit/35bbf24bc074e330a9bea852c190d8fdcbfff1ea

Peut-être vérifier si votre plugin (ça ressemble à Unity) a une version mise à jour.

J’ai supprimé l’unité de ma machine. Après l’installation de l’unité, les builds ont fonctionné pour moi. J’essayais de construire une application en utilisant robovm.

Peut-être que c’est un peu tard, mais je devais juste redémarrer Xcode après une mise à jour de Xcode et appuyer sur le bouton Installer des composants quand il apparaissait. Puis mes problèmes de git étaient partis.