Erreur SHA1 lors de l’utilisation de l’installation d’infusion

Plus précisément, j’utilisais homebrew pour installer MySQL, et j’ai eu cette erreur:

Error: SHA1 mismatch Expected: f218ed64ce6e7a5d3670acdd6a18e5ed95421d1f Got: 3a57f6f44186e0dba34ef8b8fb4a9047e9e5d8a3 Archive: /Users/rdp/Library/Caches/Homebrew/cmake-2.8.7.bottle.tar.gz (To retry an incomplete download, remove the file above.) 

Tout a fonctionné après que j’ai couru la brew update .

Incase la mise à jour de l’infusion échoue, essayez ce qui suit

 cd `brew --prefix` git remote add origin https://github.com/Homebrew/homebrew git fetch origin git reset --hard origin/master 

J’avais le même problème que Steve S en ce qui concerne la dépendance d’epstool sur Octave et j’ai trouvé ce lien:

https://github.com/Homebrew/homebrew-science/issues/1110

Découvrez le post de iml à environ 10 du haut (son deuxième post). Comme il l’a expliqué, je l’ai téléchargé à partir du site fedoraproject.org puis je l’ai déplacé dans le répertoire / Library / Caches / Homebrew /.

À votre santé,

-Maashu

Dans mon cas, le fichier téléchargé depuis https://downloads.sourceforge.net/ctags/ctags-5.8.tar.gz est en fait un fichier HTML. J’ai téléchargé le fichier réel et l’ /Library/Caches/Homebrew/ctags-5.8.tar.gz dans /Library/Caches/Homebrew/ctags-5.8.tar.gz . Puis je lance brew install ctags , tout fonctionne.