Erreur intelliJ IDEA 13: veuillez sélectionner Android SDK

J’ai installé Android SDK 22.3 et JDK 1.7 update 21 sur Win7 x64 . Maintenant, j’ai créé un projet d’application Android vide en utilisant intelliJ 13.0.1 (utilisez également Emulator comme périphérique cible) et j’ai essayé de créer le projet, mais intelliJ 13.0.1 'Error: Please select Android SDK' .

J’ai donc choisi Emulator comme Target Device , mais je n’ai pas pu sélectionner mon AVD, car il y a une Error: Cannot find any configured Android SDK .

Dans la structure du projet, la plate-forme Android 4.4.2 apparaît clairement en tant que SDK de projet. Donc, je suis totalement confus, je ne sais pas comment résoudre le problème.

ps. Je intelliJ 12.1.2 à jour intelliJ 12.1.2 à intelliJ 13.0.1 , et tous les parameters étaient automatiquement hérités de 12.1.2 lors du lancement de 13.0.1, mais il ne semble pas que tous les parameters aient été exactement copiés sur 13.0.1, ce qui est inattendu.

à votre santé

Mon problème: “veuillez sélectionner Android SDK”, mais tout va bien 🙁 – Je pense que l’un des fichiers d’IntelliJ a été planté (après l’écran bleu de la mort)

Ma résolution:

Fichier -> Paramètres -> SDK Android -> Emplacement du SDK Android Édition -> Suivant, Suivant (le SDK Android est à jour.), Terminé

… et le fichier écrasé a été réparé!

J’ai rencontré cette erreur après avoir installé Intellij IDEA Ultimate 14.1 et ouvert un projet Android existant que j’avais créé avec Android Studio. Il s’est avéré que je devais simplement append le SDK Android à ma liste de SDK et corriger les parameters du SDK de projet / module. C’est comme ça que je l’ai fait:

Allez dans File -> Project Structure . Cliquez sur l’onglet Projet sous Paramètres du projet. Sous Projet SDK, cliquez sur New -> Android SDK .

Ajout d'un nouveau SDK Android

Sélectionnez maintenant le répertoire existant pour votre SDK Android. Dans mon cas, c’était dans ce dossier:

C:\Users\\AppData\Local\Android\android-sdk

Cliquez sur OK. Un menu apparaît vous demandant de définir la cible Java SDK + Build. Vous pouvez soit les modifier, soit les laisser par défaut et appuyer sur Ok. Vous devriez maintenant voir “Plate-forme Android API XX” dans le menu déroulant Project SDK. Cliquez sur Appliquer en bas. Ensuite, allez à l’onglet Modules sous Paramètres du projet et cliquez sur les dossiers dans la liste des modules.

Liste des modules

Pour chaque dossier, accédez à l’onglet Dépendances et remplacez le SDK du module par le nouveau SDK Android, puis cliquez sur Appliquer. Cliquez ensuite sur Ok pour fermer la boîte de dialog Structure du projet.

Après avoir fait ce qui précède, mon projet a été corrigé.

J’ai eu le même problème une fois. tout semble correct. Je redémarre, supprime et invalide le cache du studio Android, reconstruit, propre et rien changé. Il est enfin résolu en cliquant sur Sync Project avec le bouton Gradle Files dans Android Studio 3.0

Bouton Synchroniser le projet avec les fichiers Gradle

Supprimez tous les SDK Android d’Intellij et ajoutez-les à nouveau .

Pour faire cette structure de projet ouverte, dans le volet SDK, supprimez tous les SDK Android, cliquez sur OK. ouvrir la structure du projet et les append à nouveau.

Si vous ne pouvez pas comstackr un projet et que vous avez ce message:

entrer la description de l'image ici

Allez dans Fichier -> Structure du projet , puis allez à la section Modules et sélectionnez votre application de module, puis sélectionnez une version Comstackr Sdk et une version Build Tools après avoir cliqué sur OK .

entrer la description de l'image ici

Attendez jusqu’à ce que gradle se synchronise et soit prêt!

J’ai fait face au problème dans IntelliJ Idea 14 en fait. Mon projet fonctionnait bien sur Android Studio. J’ai décidé de continuer le développement sur l’idée d’IntelliJ. Après l’importation du projet, je n’ai pas réussi à l’exécuter et j’ai reçu un message d’erreur similaire dans la boîte de dialog Modifier la configuration. Sur la base de ce que @Ali a dit, j’ai supprimé tous mes SDK et je les ai réinstallés, mais cela n’a pas fonctionné.

J’ai ouvert “Structure du projet”> “Paramètres de la plate-forme”> SDK. J’ai trouvé “Build target” de “Android API 21 Platform” n’est pas défini. Par régler sur l’un de mes derniers SDK, le problème a été résolu et j’ai pu exécuter le projet sans problème.

  1. Aller à la structure du projet (Ctrl + Alt + Maj + S) -> Paramètres Platforn -> SDK -> appuyer sur l’icône “Plus”
  2. Sélectionnez “Android SDK” et entrez le chemin du SDK (par exemple: C: \ Program Files (x86) \ Android \ android-sdk)
  3. Appliquer ou bouton OK
  4. Soyez heureux

dans Android 3.1.1, nous ne pouvons pas trouver de projet de synchronisation dans les outils afin que C:\Users\AndroidStudioProjects\projectname\.idea\libraries supprime les fichiers des bibliothèques et synchronise à nouveau

J’ai eu le même problème que lorsque j’ai également mis à jour l’intellij Idea 12 à 13. Dans ma situation, la cible Build de mon SDK Android n’était pas reconnue correctement. Même si j’ai choisi Android 2.2 et cliqué sur Appliquer et OK, le message “Non défini” s’affiche à nouveau lorsque j’ai rouvert la boîte de dialog de structure du projet.

Ensuite, j’ai choisi une autre version, Android 4.0 cette fois, cliqué sur Appliquer, puis choisi à nouveau Android 2.2, cliqué sur Appliquer. Cela a fonctionné pour moi.

Peut-être pas une solution si commune, mais pour moi, le redémarrage de l’IDE fonctionnait très bien. J’utilise Android Studio 2.2.3 .

Vérifiez les lignes suivantes dans votre fichier app build.gradle.

 android { comstackSdkVersion 25 <--- Set exist in local machine sdk version. buildToolsVersion '25.0.3' <--- Set exist build tools version. } 

Fichier -> Invalidate Caches / Restart a fait l’affaire (ce qui est toujours un bon premier essai)

Vous devez sélectionner Build Tool Version à partir de votre paramètre de projet.

  1. Sélectionner un dossier d’application de projet
  2. Appuyez sur F4 OU Cliquez avec le bouton droit sur Dossier App Project et ouvrez Paramètres du module Dans l’onglet Propriétés, sélectionnez la version de l’outil Générer dans la liste.

Cela fonctionnera de mon côté j’espère que cela vous aidera.

vérifiez si vous avez installé tous les modules complémentaires nécessaires. Aussi, je vous recommande d’utiliser un vrai téléphone Android pour le débogage. C’est mieux, c’est réel et plus rapide.

Cela ressemble beaucoup à IDEA qui ne trouve pas le SDK Android.

Vous avez redémarré l’ordinateur après avoir utilisé Android SDK Installer?

Après cela, avez-vous démarré le SDK Manager pour installer le SDK Android 4.2.2?

Pouvez-vous vérifier la variable d’environnement Android_SDK_HOME?

Tenez compte du fait que le programme d’installation du SDK Android installe simplement un gestionnaire. Après cela, vous devez installer un SDK (ou plusieurs).

En outre, lorsque vous voyez la plate-forme Android 4.4.2 dans la structure du projet, cela signifie que le projet demandera ce SDK. Cela ne signifie pas que le SDK a été installé.

J’avais un problème similaire. J’ai dû append le même SDK Android que celui que j’avais utilisé auparavant et cela a fonctionné.

il y a un bouton par nom android monitor en bas à gauche de l’écran. Si vous rencontrez un problème avec sdk, il affichera le lien de configuration. Changez le chemin de votre dossier sdk. les choses vont marcher