Visual Studio 2013 ou 2015 EditorPackage ne s’est pas chargé correctement en permanence

Au démarrage de Visual Studio 2013 Pro (mise à jour 4 installée), je reçois très souvent ce message d’erreur (plusieurs fois par jour maintenant) depuis environ deux semaines:

Le package ‘Microsoft.VisualStudio.Editor.Implementation.EditorPackage’ ne s’est pas chargé correctement.

Je sais que je peux corriger ce problème en fermant Visual Studio et en supprimant:

%LocalAppData%\Microsoft\VisualStudio\12.0\ComponentModelCache 

Je ne l’ai jamais vu avant cette date et pour autant que j’ai découvert sur Internet, il a été éventuellement introduit avec la mise à jour 3.

Eh bien, le problème est qu’il est ennuyeux de redémarrer Visual Studio plusieurs fois par jour, et je me demandais si quelqu’un d’autre le ressentait et savait comment le résoudre définitivement ou quelle en était la cause.

J’ai remarqué que cela arrive très souvent si je travaille en parallèle sur plusieurs instances de Visual Studio. Celui-ci est un tueur. Mais je soupçonne quand même qu’un composant tiers soit impliqué ou que c’est la taille d’une des solutions (environ 70 projets). J’ai essayé de désactiver certaines extensions nouvellement installées et nécessaires pour le grand projet, mais en vain.

Juste comme information: je travaille avec C # . Lorsque je travaillais en parallèle avec des projets ouverts dans plusieurs instances de Visual Studio, je n’avais jamais rencontré de problèmes auparavant.

Quelqu’un at-il le même problème à cet égard ou peut-être une meilleure solution que la suppression du dossier et le redémarrage?

C’est devenu une question populaire, alors j’ai pensé append une réponse explicite à la manière de (au moins) corriger temporairement le problème, comme indiqué dans la question:

J’arrête Visual Studio et supprime le dossier suivant (complètement, pas seulement le contenu)

 %LocalAppData%\Microsoft\VisualStudio\12.0\ComponentModelCache 

Si vous utilisez VS2015, le chemin doit être:

 %LocalAppData%\Microsoft\VisualStudio\14.0\ComponentModelCache 

Si vous utilisez VS2017, le chemin doit être:

 %LocalAppData%\Microsoft\VisualStudio\15.0\ComponentModelCache 

Je ne garde pas de sauvegarde du dossier. Il est créé à nouveau automatiquement lors du démarrage de Visual Studio.

Je n’ai jamais trouvé de solution pour résoudre définitivement le problème dans cet environnement de travail. Dans mon nouvel environnement en développement (nouveaux projets et nouveaux lieux de travail), le problème ne se pose jamais.

C’est ce qui m’a aidé … semblait se produire après l’installation de Windows Server 2012 SP …

https://connect.microsoft.com/VisualStudio/feedback/details/1123745/setsite-failed-for-package-microsoft-visualstudio-editor-implementation-editorpackage

  1. devenv /clearcache
  2. devenv /updateconfiguration

Dans ce cas, vous pouvez redémarrer l’installation de Visual Studio et choisir l’option affichant deux options, Réparer et Désinstaller . Cliquez ensuite sur Réparer et, une fois la réparation terminée, redémarrez l’ordinateur. Ensuite, le problème a été résolu.