Pourquoi le déploiement Azure est-il plus lent sur Windows 2012 Server que sur Windows 2008 Server?

J’ai un ASP.NET (Webforms) fonctionnant avec .Net Framework 4.0.

Si je déploie ce site avec osFamily="1" (sur un serveur Windows 2008), le .NET CLR prend en moyenne 120 ms (selon les journaux NewRelic).

Si je prends le site exact et que je le déploie avec osFamily="3" (sur un serveur Windows 2012), le .NET CLR prend plus de 500 ms .

Je sais que je devrais passer à MVC4 et peut-être à .Net Framework 4.5 , mais j’aimerais savoir si quelqu’un d’autre a eu le même problème et si vous savez ce qui pourrait en être la cause?

entrer la description de l'image ici

modifier

On dirait que osFamily=2 aussi le même problème.

    De la discussion du forum, il semble que ce soit un problème connu.

    Le problème est signalé ici .

    Mise à niveau de VS2010 à VS2012, nous avons constaté que le déploiement est très lent, ce qui peut être contourné, mais le passage au code est également très lent.

    Tout d’abord, nous avons pensé que c’était peut-être le périphérique, mais il est très lent même dans l’émulateur. Cette machine que nous avons testée est un processeur i7 avec 12 Mo de RAM. Cela semble également être le cas pour beaucoup de ceux qui ont signalé sur nos forums.

    En savoir plus

    Une solution semble être le changement du pilote en winusb ( C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb ) – selon l’un des commentaires.

    http://social.msdn.microsoft.com/Forums/windowsazuree/en-us/7cf664b0-5876-4d6a-b54d-fda46c544c6f/azuree-deployment-slower-with-w2012-server-than-w2008-server-or- w2008-server-r2? forum = windowsazureetroubleshooting :

    J’ai essayé avec .NET 4.5 avec les mêmes résultats. Je pense que quelque chose est lié à Azure SDK 1.7 et 2.0

    Configurer le client de cache Azure par programme ‘Answer by Jordi Torra

    Il semble y avoir un problème avec Azure SDK 1.7 & 2.0.