La cible du projet (Android L (Preview)) n’était pas correctement chargée

Récemment, j’ai mis à niveau Eclipse avec des ADT plugin vers Android L priew .

J’ai aussi la dernière mise à jour de Java 8 savoir Java 8 .

Je n’ai pas pu voir la mise en page et elle s’affiche comme ci-dessous

entrer la description de l'image ici

S’il vous plaît, notez cette icône Android dans la partie supérieure de l’écran

Icône Android

Cette icône est dans la partie supérieure de cet écran:

Écran qui affiche la version de l'API pour rendre le code

Il affiche probablement le numéro 20. C’est la sélection pour utiliser l’API 20 pour afficher la fenêtre. Changer à 19 ou 20W (pas 20L). Ça va régler le problème.

API 19 sélectionnée

Vous devrez peut-être également modifier la configuration d’eclipse pour s’exécuter sur Java 7 Runtime.

Ajoutez ceci au début de eclipse.ini

 -vm C:/Program Files/Java/jre7/bin 

Pour ceux qui ont le même problème: vous n’avez pas besoin de désinstaller Java 6. Il vous suffit de le définir correctement sur Eclipse.

  1. Commencez par avoir le JDK pour Java 8 (aussi appelé Java 1.8) à l’ adresse suivante : http://www.oracle.com/technetwork/java/javase/downloads/index.html
  2. Installez-le normalement.
  3. Accédez aux préférences Eclipse et à Java -> JRE installés
  4. “Ajouter …” -> Standard VM -> Suivant et rechercher le chemin d’installation (sur Mac, il s’agira de quelque chose comme: /Library/Java/JavaVirtualMachines/jdk1.8.0_20.jdk/Contents/Home).
  5. Entrez un joli nom comme “Java JDK 1.8” et Terminez
  6. Assurez-vous de marquer le nouvel JRE comme indiqué sur l’image entrer la description de l'image ici
  7. Redémarrez Eclipse pour que les modifications prennent effet.

Cela semble être le problème… le «choix automatique optimal», choisit la version «L» de l’API 20 au lieu de la version 4.x de l’API 20. Dans mon cas, je cible l’API 19 et apparemment, ce n’est pas le cas. compatible avec le choix de “API 20: Android L (Preview)”.

Désolé, ce système ne me laissera pas encore poster des images …

Vous pouvez voir la note suivante dans https://developer.android.com/preview/setup-sdk.html

Remarque: Le plug-in Eclipse ADT nécessite Java 7 si votre cible de compilation est l’aperçu du développeur L.

Peut-être que Java 7 n’est pas installé?

Le problème pour cela est d’avoir différentes versions de jre

J’ai java 6 and 8 tous les deux installés sur mon système, alors j’ai désinstallé java 6 et défini le chemin pour seulement java 8.

Mais n’oubliez pas de redémarrer le système après avoir défini les chemins.

Maintenant, l’erreur a disparu lors de la visualisation de Android L Preview

Vérifiez votre version de JDK. Ce doit être JDK1.7. JDK 1.6 ne fonctionne pas.

OPen SDK Manager -> Désinstallez Android L (API 20, aperçu L), utilisez-le si vous souhaitez résoudre cette erreur rapidement

Ce que j’ai fait après la mise à jour de Java a été de rétablir le système de variables pour Java

Paramètres système avancés -> Avancé -> Variables d’environnement.

J’ai mis à jour JAVA_HOME avec ce répertoire

C: \ Program Files \ Java \ jdk1.7.0_60

De retour en éclipse, vous pouvez soit:

Cliquez sur Propriétés -> Android -> Cible de génération de projet

Changer android L pour Android 4.4

Si vous voulez utiliser Android L, changez le manifeste minSdkVersion en “L”

Dans mon cas, ma version actuelle de Java est la 1.6.

Donc, je lance la commande ‘update-alternatives –config java’ pour changer la version en java 1.7, puis redémarre l’Eclipse, le problème est résolu.

Note: J’ai installé la version muti-java (Java 1.6 et java 1.7)

J’espère vous aider.