Non compatible avec votre système d’exploitation ou votre architecture: fsevents@1.0.11

J’utilise Ubuntu 15.04. En exécutant la commande suivante:

npm install fsevents 

Je reçois l’erreur suivante:

 npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.11 npm WARN tutorial@1.0.0 No repository field. 

Quelqu’un a-t-il résolu ce problème?

    J’étais confronté au même problème avec cette dépendance lors de la création d’autres applications.

    Juste pour des raisons de connaissance et pour les personnes qui ne sont pas bien habituées à NPM, et donc incertaines sur la manière dont leurs applications se comporteront:

    fsevents étant une API sous OS X, les applications fsevents s’enregistrer pour recevoir des notifications de modifications sur une arborescence de répertoires donnée . Fonctionnement:

    npm install --no-optional

    Fera le tour, sans inconvénients.

    Ce n’est pas une erreur, c’est juste un avertissement: c’est une dépendance facultative.

    Vous pouvez dire à npm de ne pas installer les dépendances optionnelles par défaut en utilisant la ligne de commande ci-dessous:

     npm config set optional false 

    J’ai eu le même problème avec la dépendance. Veuillez vérifier le fichier package.json, append “typings”: entrée “^ 0.8.1” sous la section devDependency. N’oubliez pas d’append une virgule avant 🙂 J’espère que cela va résoudre le problème.

    J’étais également confronté à cette erreur lors de l’installation de Redux :

     $ npm install --save react-redux npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.14 

    Ce qui a résolu le problème était d’append --no-optional (l’ argument empêchera l’installation de dépendances facultatives ):

     npm install --no-optional --save react-redux ^^^^^^^^^^^^^ 

    Et maintenant, il est correctement installé:

     $ npm ls redux ReduxProject@ /home/me/projects/reduxproject └── redux@3.5.2