Les identificateurs de couleur ReSharper gondent avec le thème sombre de Visual Studio 2012

Nous rencontrons un problème gênant avec la fonctionnalité d’identifiants de couleur de ReSharper lorsque Visual Studio 2012 est défini sur le thème sombre intégré.

Avec les identificateurs de couleur de ReSharper désactivés, le code semble correct:

Code semble bien

Ensuite, nous activons les identificateurs de couleur de ReSharper:

Paramètres d'inspection du code ReSharper

Et maintenant, le code est complètement illisible:

Un code illisible

La chose curieuse, sur la machine d’un collègue, le même code, avec les mêmes parameters Visual Studio et ReSharper … semble correct:

Un code beau

Nous avons essayé de réinitialiser à la fois les parameters de Visual Studio et de ReSharper, de désactiver les add-ons et les extensions, ainsi que d’autres voodoos, en vain.

Voici nos configurations:

  • Mes compléments – Ses compléments
  • Mes extensions – Ses extensions
  • Mes informations système – Ses informations système

J’ai eu le même problème avec vs2013 et resharper 8. J’ai pu corriger en procédant comme suit:

  1. Fermez toutes les instances de Visual Studio
  2. Ouvrez le fichier C: \ Program Files (x86) \ Microsoft Visual Studio {Version VS} \ Common7 \ IDE \ Extensions \ extensions.configurationchanged
  3. Tapez quelque chose là
  4. Enregistrez le fichier
  5. Ouvrez VS et vérifiez les fonts et les couleurs dans les outils | Options | Environnement

source http://resharper-support.jetbrains.com/ensortinges/26859128-ReSharper-Fonts-Colors-settings-do-not-appear-in-Visual-Studio-after-installation

J’ai eu le même problème dans VS2013, malheureusement, l’édition du fichier de configuration ne fonctionnait pas pour moi. Cependant, j’ai résolu le problème en procédant comme suit:

  1. supprimer la clé de registre suivante:

HKCU \ Software \ Microsoft \ VisualStudio \ 12.0_Config

  • Exécuter devenv /ResetSettings partir de l’invite de commande admin VS 2013
  • En différenciant nos informations système, j’ai remarqué trois add-ins que mon collègue n’avait pas (JetBrains TeamCity Addin 7.1, VisualSVN 3.0.5 et Git Extensions).

    En essayant de les désactiver un par un, j’ai découvert que le coupable était le complément de TeamCity : dès que je l’ai désinstallé (il n’est pas signalé dans Visual Studio et que vous ne pouvez pas le désactiver),

    La chose amusante est que ReSharper et les compléments TeamCity sont fournis par JetBrains.

    C’est un bogue connu dans le programme d’installation de TeamCity Addin. Il a été corrigé dans la version 7.1.5. S’il vous plaît, examinez le problème associé dans notre tracker et les notes de version 7.1.5 .

    J’utilise un thème sombre personnalisé dans Visual Studio 2010 et probablement environ 75% de la première fois que j’ouvre une solution, ReSharper 7.1.1 fait exactement la même chose que dans votre image “illisible”. Je veux dire, les couleurs sont exactement comme ça.

    Je l’ai testé sur plusieurs ordinateurs sans plug-ins, à l’exception de ReSharper, et avec divers autres plug-ins et quoi qu’il arrive, je l’obtiens tout le temps. Je n’ai pas TeamCity Addin du tout et je n’ai jamais.

    Quoi qu’il en soit, si quelqu’un cherche une solution, cela résout le problème: Outils> Options> Environnement> Polices et couleurs> Ok. C’est tout. Même aucune modification ne l’affiche et ne s’affiche pas correctement. Je ne peux pas l’empêcher, mais cela résout le problème et c’est la première étape que je fais à chaque fois que j’ouvre VS2010.

    J’espère que cela aide quelqu’un.

    J’utilise VS2013 et j’ai eu le même problème. Dans mon cas, le coupable était l’extension PowerShell Tools, après l’avoir désinstallée, le schéma de couleurs est revenu à un état sain.