Articles of android support bibliothèque

RecyclerView éléments avec un grand espace vide après 23.2.0

Après la mise à jour vers la v23.2.0 dans mon RecyclerView j’ai des éléments avec un énorme espace vertical vide entre les éléments. Ma mise en page est très simple:

La présentation graphique de FragmentTabHost ne rend pas

La disposition graphique pour un simple android.support.v4.app.FragmentTabHost ne rend jamais dans Eclipse ou Android Studio. L’erreur de console que j’obtiens est constamment: Exception raised during rendering: No tab known for tag null J’utilise le fichier XML le plus basique: mais la même erreur se produit. Je voulais juste append plus de vues au-dessus ou au-dessous […]

IDE «Impossible de résoudre @ style / Theme.Appcompat» lors de l’utilisation du thème de support de compatibilité v7

Ce n’est pas vraiment un problème majeur, car mon projet est toujours construit et fonctionne correctement (avec gradle), mais j’ai du mal à faire en sorte que Android Studio reconnaisse le thème de compatibilité des applications du SDK API 18 et ci-dessus). Les bibliothèques de support se chargent avec succès, car la complétion du code […]

Comment append Android Support Repository à Android Studio?

J’utilise Android Studio avec un SDK Android externe. J’ai installé la bibliothèque de support et le référentiel de support. Le référentiel de support se trouve dans: ~/Development/Tools/android/sdk/extras/android/m2repository Lorsque j’ajoute une dépendance à la bibliothèque de support dans le fichier build.gradle , par exemple: … repositories { mavenCentral() } … dependencies { comstack “com.android.support:support-v4:18.0.+” } Android […]

Le sharepoint vue du recycleur remplit toute la hauteur de la vue du recycleur après la mise à niveau de la bibliothèque de support de «23.1.1» à «23.2.1»

Auparavant, j’utilisais les anciennes bibliothèques de support suivantes “23.1.1”. comstack ‘com.android.support:appcompat-v7:23.1.1’ comstack ‘com.android.support:support-v4:23.1.1’ comstack ‘com.android.support:preference-v7:23.1.1’ comstack ‘com.android.support:preference-v14:23.1.1’ comstack ‘com.android.support:design:23.1.1’ comstack ‘com.android.support:recyclerview-v7:23.1.1’ Ça marche plutôt bien. Voici à quoi ressemble mon RecyclerView Maintenant, je souhaite migrer vers “23.2.1”, en raison de certaines corrections de bugs effectuées. comstack ‘com.android.support:appcompat-v7:23.2.1’ comstack ‘com.android.support:support-v4:23.2.1’ comstack ‘com.android.support:preference-v7:23.2.1’ comstack ‘com.android.support:preference-v14:23.2.1’ comstack ‘com.android.support:design:23.2.1’ […]

Android: Contrôlez Smooth Faites défiler la vue du recycleur

J’utilise Recyclerview avec CardView. Je sais comment contrôler la vitesse en vue liste. Mais pas pour Recyclerview. J’ai beaucoup cherché dans le nom de classe trouvé SmoothScroll . Comment l’utiliser? Je n’ai aucune idée! En ce moment, Recyclerview par défaut défilement est rapide. METTRE À JOUR: J’ai résumé Gil Answer avec ceci

Impossible de résoudre le symbole HttpGet, HttpClient, HttpResponce dans Android Studio

Je viens de copier tous les fichiers jar de Http mais Android Studio peut pas importer tous ces fichiers jar. Il donne une erreur: Cannot resolve symbol HttpGet,HttpClient,HttpResponse . Mon fichier d’ Activity est ici: – public class MainActivity extends AppCompatActivity { ArrayList productslist; ProductAdapter adapter; @Override protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.activity_main); productslist […]

Android Support Repo 46.0.0 avec Android Studio 2.3

J’ai mis à jour aujourd’hui mon référentiel de support en 46.0.0 lorsque la notification Android Studio est apparue. Je vais l’erreur ci-dessous: Erreur: L’exécution a échoué pour la tâche ‘: app: processDevDebugManifest’. La fusion du manifeste a échoué: atsortingbut meta-data#android.support.VERSION@value valeur = (25.3.0) à partir de [com.android.support:support-v13:25.3.0] AndroidManifest.xml: 27: 9-31 est également présent à [com.android.support:preference-v7:26.0.0-alpha1] […]

Utiliser un vecteur Android Drawables sur un crash avant Lollipop

J’utilise des dessins vectoriels dans Android avant Lollipop et ceux-ci sont de certaines de mes bibliothèques et versions d’outils: Android Studio: 2.0 Android Gradle Plugin: 2.0.0 Outils de construction: 23.0.2 Bibliothèque de support Android: 23.3.0 J’ai ajouté cette propriété au niveau de mon application Build.Gradle android { defaultConfig { vectorDrawables.useSupportLibrary = true } } Il […]

Comment déterminer le fragment restauré du backstack

Vous avez cherché ce problème pendant un certain temps en vain maintenant: Comment déterminer le fragment est restauré de backstack? J’utilise la bibliothèque de compatibilité et un object ListFragment dans un FragmentActivity. Lorsqu’un élément dans ListFragment est sélectionné, un nouveau fragment est lancé pour remplacer le composant ListFragment. J’ai remarqué que lorsque FragmentActivity est mis […]