Articles of éclipse

Utiliser android.support.v7.widget.CardView dans mon projet (Eclipse)

Je voudrais utiliser le nouveau widget CardView qui a été introduit avec la nouvelle bibliothèque de support de prévisualisation Android L Developer (comme mentionné ici ), qui semble faire partie d’une nouvelle révision de la bibliothèque de support v7. J’ai maintenant mis à jour ma version de SDK, téléchargé le dernier package de bibliothèque de […]

Aucun numéro de ligne dans l’éditeur XML Eclipse ou Android Studio

Lors de la modification de fichiers XML dans l’éditeur pour Eclipse, les numéros de ligne ne sont pas affichés. Cas d’utilisation: Je crée une mise en page avec beaucoup de vues, dont l’une manque d’Android: atsortingbut layout_width. Cela provoque une erreur d’exécution lorsque la ressource de présentation XML binary est gonflée. Le journal des erreurs […]

Pourquoi SpringSource Tool Suite (STS) est-il si lent? Et comment puis-je le réparer?

J’utilise STS 2.3.2 sur un MacBook Pro depuis quelques jours. Je trouve que les performances sont significativement plus lentes que toute autre version d’Eclipse que j’ai utilisée. Par exemple, le passage d’un onglet à un autre peut prendre jusqu’à 4 secondes. J’ai essayé de désactiver une grande partie de la validation et d’augmenter la mémoire, […]

Des choses possibles dans Eclipse qui ne sont pas possibles dans IntelliJ?

J’ai entendu des gens qui ne jurent que par l’un ou l’autre. Les deux sont des IDE excellents et complets. Mais chacun a des forces légèrement différentes. Ceci n’est pas destiné à se transformer en une guerre sainte IDE. Veuillez noter les réponses à vos questions. Merci. C’est l’analogue de cette question .

Paramètres de mémoire Eclipse lors de l’obtention de «Java Heap Space» et «Out of Memory»

En essayant de lancer et d’exécuter un projet flex / java dans eclipse, je continuais à obtenir une “exception de mémoire insuffisante” et un “espace de tas Java” utilisant Eclipse, Tomcat et un JRE. Lors de la recherche d’essayer d’ajuster les parameters de mémoire, j’ai trouvé trois endroits pour les ajuster: Eclipse.ini Les parameters JRE […]

Profilage d’applications Android avec le plugin Eclipse TPTP au lieu de la vue de trace

La méthode standard pour profiler une application Android dans Eclipse consiste à utiliser le plug-in DDMS et à créer un fichier de trace contenant toutes les informations. Si vous souhaitez afficher ces informations, vous pouvez utiliser “traceview”. Je n’ai pas aimé ma première expérience avec cette application car vous ne pouvez pas filtrer les résultats. […]

Comment append la bibliothèque «Maven Managed Dependencies» dans l’éclipse du chemin de compilation?

J’ai créé un projet Maven et je souhaite append toutes les dépendances Maven dans le chemin de construction du projet dans Eclipse . Lorsque je vais dans Java Build Path> Ajouter une bibliothèque> Maven Managed Dependency> Suivant dans la boîte de dialog de propriétés du projet, il me demande d’utiliser “Maven Project Setting” pour configurer […]

Importation de ant build.xml dans Eclipse

J’ai un projet Android qui utilise ant pour construire, est-il possible d’importer ce projet ant dans l’IDE Eclipse? update: Il existe une option pour créer un projet en utilisant ant build.xml dans eclipse File-> New-> Project-> Java-> Java du projet existant Buildfile. et si le fichier build.xml est sélectionné, afficher l’erreur Le Specified buildfile does […]

Existe-t-il un plug-in JSLint Eclipse fonctionnel?

Quelqu’un peut-il désigner un plug-in JSLint fonctionnel pour Eclipse?

Ce SDK Android nécessite Android Developer Toolkit version 23.0.0 ou supérieure

J’obtiens l’erreur suivante lorsque je démarre mon Eclipse. Et lorsque j’essaie de mettre à jour depuis Aide> Installer un nouveau logiciel … en utilisant le lien de mise à jour eclipse https://dl-ssl.google.com/eclipse/plugin/4.2 Cela me donne l’erreur suivante: Cannot complete the install because of a conflicting dependency. Software being installed: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982) […]