Articles of éclipse

JVM incompatible dans GGTS (Eclipse) et JAVA 1.8

Avoir un problème avec l’exécution d’une application grails dans GGTS (eclipse) en raison de la mise à niveau vers Java 1.8. La stack commence par: Mar 05, 2015 3:51:31 PM org.springsource.loaded.jvm.JVM copyMethod SEVERE: Problems copying method. Incompatible JVM? java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor91.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at org.springsource.loaded.jvm.JVM.copyMethod(JVM.java:134) at org.springsource.loaded.ri.OriginalClassInvoker.createJavaMethod(OriginalClassInvoker.java:68) at org.springsource.loaded.ri.ReflectiveInterceptor.jlClassGetDeclaredMethods(ReflectiveInterceptor.java:151) at org.codehaus.groovy.reflection.CachedClass$3$1.run(CachedClass.java:84) at […]

java.lang.NoClassDefFoundError: org / apache / juli / logging / LogFactory

J’ai en fait compris ce problème, mais cela m’a pris des jours, alors j’ai pensé coller ici ma solution pour aider les autres. J’utilise Fedora 11 et dans Eclipse, j’ai essayé d’append un serveur Tomcat 6 et de le démarrer. Je voudrais obtenir l’erreur suivante: “Démarrer Tomcat v6.0 Server at localhost” a rencontré un problème. […]

Comment puis-je empêcher que l’onglet «Servers» d’Eclipse ne prenne le focus lors du démarrage / arrêt d’un serveur?

Lorsque vous utilisez Eclipse IDE, à chaque fois que le serveur (tomcat dans mon cas) change d’état (démarrage, démarrage, arrêt, arrêt, etc.), l’onglet Servers devient actif. C’est ennuyant parce que je ne peux pas voir la console. Par défaut, je pense que la console a “Afficher la console en cas de modifications std-out / err”, […]

spécifiant but dans pom.xml

Je crée un nouveau projet pom.xml avec pom.xml comme ci-dessous: – 4.0.0 firstRestlet restlet1 0.0.1-SNAPSHOT war restlet1 http://maven.apache.org maven-restlet Public online Restlet repository http://maven.restlet.org UTF-8 junit junit 3.8.1 test Le problème auquel je suis confronté est que le fichier de guerre cible n’est pas généré. Sur la console eclipse après avoir exécuté ce pom.xml les […]

Puis-je append JavaDoc à un package facilement avec Eclipse?

J’utilise javadoc pour documenter mes classes et méthodes. J’aimerais aussi append des informations générales sur mes paquets. J’aime comment Eclipse crée un stub correspondant à un commentaire de document pour chaque classe ou méthode une fois que je tape /** . Eclipse dispose-t-il également d’un moyen simple de générer un fichier package.html ?

Un moyen de générer automatiquement tous les commentaires Javadoc dans Eclipse?

Je sais que vous pouvez appuyer sur Maj + Alt + J pour insérer un modèle de commentaire approprié pour le bloc de code en cours, mais y a-t-il un moyen de laisser éclater éclipse et de faire un projet comme celui-ci?

‘Aucun test JUnit trouvé’ dans Eclipse

Donc, je suis nouveau sur JUnit, et nous devons l’utiliser pour un devoir. Notre professeur nous a donné un projet qui comporte une classe de test, BallTest.java . Lorsque je fais un clic droit> Exécuter en tant que> Test JUnit, j’obtiens une erreur contextuelle indiquant “Aucun test JUnit trouvé”. Je sais que la question a […]

Fusion de twig en tronc dans SVN en utilisant Eclipse

Je suis impatient de fusionner mes codes que j’ai développés dans une twig de SVN au tronc. J’utilise Eclipse et j’utilise Team-> Commit pour valider mes mises à jour sur le SVN. Mais je n’ai pas fait de fusion avant. S’il vous plait, j’ai besoin de votre aide avec ceci. Merci

Problème d’émulateur dans Android

Lorsque je lance l’émulateur, je suis confronté à de nombreux problèmes (erreurs): – HttpConnectionApp]emulator-5554 disconnected! Cancelling ‘net.paxcel.http.HttpConnectionApp activity launch’! Emulator]emulator: ERROR: the user data image is used by another emulator. aborting Chaque fois, je dois le relancer mais en vain. Comment puis-je l’améliorer pour pouvoir relancer l’application sur le même AVD?

Bibliothèque système Eclipse JRE

J’utilise Eclipse EE 3.7 avec le plugin m2e installé. J’ai JDK7 mis en éclipse. Lorsque j’importe des projets Maven, le JRE est défini sur JRE System Library [J2SE-1.5] . J’ai donc des problèmes de compilation avec les choses liées à Java 6. Au lieu de cela, je veux que JRE dans eclipse soit défini par […]