Articles of éclipse

Comment mettre à niveau Eclipse pour les développeurs Java EE?

Existe-t-il un moyen non douloureux de mettre à niveau une installation Eclipse? J’ai essayé de naviguer sur le site de l’éclipse mais je ne trouve pas de description utile.

Comment supprimer les avertissements Java pour des répertoires ou des fichiers spécifiques tels que le code généré

J’utilise un générateur d’parsingur qui crée un code un peu laid. Par conséquent, mon projet Eclipse a plusieurs dizaines d’avertissements émanant des fichiers source générés. Je sais que je peux utiliser l’annotation @SuppressWarning pour supprimer des avertissements particuliers dans des éléments particuliers, mais les annotations que j’appendai à la main seront perdues lorsque le générateur […]

Quel IDE Android est le meilleur – Android Studio ou Eclipse?

Je commence à développer pour Android. Quel IDE dois-je utiliser – Android Studio ou Eclipse sdk? Je voudrais savoir lequel est le meilleur.

java.lang.IllegalArgumentException: AppCompat ne prend pas en charge les fonctionnalités de thème actuelles

J’ai essayé de migrer un projet d’Eclipse vers un studio Android. Enfin, je suis capable de l’exécuter, mais à un certain moment j’ai eu cette exception, et je n’ai rien trouvé dans Google à ce sujet: 04-22 00:08:15.484 9891-9891/hu.illion.kwindoo E/AndroidRuntime﹕ FATAL EXCEPTION: main java.lang.RuntimeException: Unable to start activity ComponentInfo{hu.illion.kwindoo/hu.illion.kwindoo.activity.MainActivity}: java.lang.IllegalArgumentException: AppCompat does not support the […]

SLF4J: Impossible de charger la classe «org.slf4j.impl.StaticLoggerBinder». Erreur

Concernant Eclipse IDE ( Indigo , Juno et Kepler (versions 32 et 64 bits)) Plateformes : Windows , Ubuntu , Mac version m2e : 1.1.0.20120530-0009 , 1.2.0.20120903-1050 , 1.3.0.20130129-0926 , 1.4.0.20130601-0317 Informations générales L’erreur ci-dessus est survenue après la mise à jour du m2e vers la version 1.1. En supprimant m2e 1.1 et en revenant […]

Gestionnaire d’événements de modification du projet JPA Eclipse (attente)

Pourquoi est-ce que j’obtiens le gestionnaire d’événement de changement de projet JPA (attente) chaque fois que j’essaie de construire mon projet? J’ai des projets JPA dans mon espace de travail et la construction de mon projet prend beaucoup de temps. Il conduit également à la limite de GC avec 6 Go d’espace de tas alloué […]

Le moyen le plus simple de mettre à jour eclipse 3.7 à 4.2 (Juno)

Donc, comme Eclipse juno est basé sur 4.2 au lieu de 3.7, quel est le moyen le plus simple de le mettre à niveau, sans installer une copie séparée de juno et réinstaller tous mes plug-ins existants depuis la version 3.7? Il ne semble pas y avoir de chemin de mise à niveau simple mentionné […]

Obtenir «CHECKOUT ne peut être exécuté que sur une ressource de version» lors de la tentative de validation à l’aide du plugin subversif Eclipse

J’utilise Eclipse Juno sur Mac 10.7.5, SVN 1.7 et le plugin Eclipse Subversive. Occasionnellement, quand j’essaie et commets des modifications de mon projet (en faisant un clic droit sur le projet depuis l’explorateur de paquets, en sélectionnant “Team” -> “Commit”), j’obtiens l’erreur: Some of selected resources were not committed. Some of selected resources were not […]

web.xml est manquant et est défini sur true

Considérer: Lorsque je crée un projet Maven simple dans Eclipse, je reçois cette erreur: web.xml est manquant et est défini sur true Comment puis-je résoudre ce problème?

Eclipse: une erreur s’est produite lors du filtrage des ressources

Je construis un projet Spring MVC et Eclipse lance cette erreur (voir capture d’écran). Mon pom.xml est: 4.0.0 com.bilitutor.cct BiliTutor 1.0.0-SNAPSHOT war 3.1.1.RELEASE 1.6.10 1.6.6 org.springframework spring-web ${spring.version} org.springframework spring-webmvc ${spring.version} org.springframework spring-orm ${spring.version} javax.servlet javax.servlet-api 3.1.0 provided cglib cglib 2.2.2 commons-dbcp commons-dbcp 1.2.2 mysql mysql-connector-java 5.1.20 org.hibernate hibernate-core 4.1.3.Final javax.validation validation-api 1.1.0.Final org.hibernate hibernate-validator […]