Articles of package managers

Erreur lors de la tentative de mise à jour du gestionnaire de packages d’infusion

J’ai essayé de mettre à jour l’infusion: sudo brew update Mais j’ai cette erreur: erreur: vos modifications locales apscopes aux fichiers suivants seraient écrasées par la fusion: Liste de nombreux fichiers Erreur: Échec lors de l’exécution de git pull http://github.com/mxcl/homebrew.git master Une idée de ce qui ne va pas?

Comment importer une version spécifique d’un package utilisant go get?

venant d’un environnement Node , j’avais l’habitude d’installer une version spécifique d’une lib fournisseur dans le dossier du projet ( node_modules ) en indiquant à npm d’installer cette version de cette lib depuis le package.json ou même directement depuis la console, comme ceci: $ npm install express@4.0.0 Ensuite, j’ai importé cette version de ce package […]

Gestionnaire de paquets: Bower vs jspm

En quoi Bower est-il différent de jspm ? Bower peut-il fournir des fonctionnalités jspm sur le chargeur de modules universel SystemJS ?

Pourquoi utiliser les dépendances par les pairs dans npm pour les plugins?

Pourquoi, par exemple, un plug-in Grunt définit-il sa dépendance à grunt comme ” dépendances par les pairs “? Pourquoi le plugin ne peut-il pas avoir Grunt comme propre dépendance dans grunt-plug / node_modules ? Les dépendances entre pairs sont décrites ici: https://nodejs.org/en/blog/npm/peer-dependencies/ Mais je ne comprends pas vraiment. Exemple Je travaille actuellement avec les stéroïdes […]

Qu’est-ce que cela signifie: Failure ?

J’essaie de déployer mon application et parfois d’obtenir cette erreur: Failure [INSTALL_FAILED_CONTAINER_ERROR] J’ai essayé de le faire sur Google, mais je ne trouve pas ce que l’erreur signifie ou ce que cela cause. Je déploie via IDE (IntelliJ) le fichier est copié sur le périphérique vers / data / local / tmp (Huawei Ideos sans […]

Comment lister les paquets installés par les utilisateurs npm?

Comment lister le paquet installé par l’utilisateur UNIQUEMENT dans npm ? Lorsque je fais npm -g list il affiche tous les paquets et leurs dépendances, ce qui n’est pas ce que je veux.