Articles of RVM

comment annuler la mise à jour de bundle

bundle update et l’ bundle install sont fantastiques. Cependant, y a-t-il un bon moyen d’ undo bundle install et la bundle update cas de problème?

Message d’avertissement reçu «Chemin défini sur RVM» après la mise à jour de la version ruby ​​à l’aide de rvm

Récemment, j’ai essayé de mettre à jour ma version ruby ​​en raison d’un message d’avertissement (voir ci-dessous). Maintenant, je reçois le message d’avertissement suivant lorsque je démarre mon iterm2: Warning: PATH set to RVM ruby but GEM_HOME and/or GEM_PATH not set, see: https://github.com/wayneeseguin/rvm/issues/3212 Est-ce que quelqu’un sait comment résoudre cet avertissement? Cela n’a pas vraiment […]

Pourquoi devrais-je me soucier de la fonctionnalité Gemset de RVM lorsque j’utilise Bundler?

Je ne comprends tout simplement pas. Je pensais, Bundler a été développé pour résoudre les conflits de version entre les gemmes. Donc, je dois juste require “bundler/setup” et tout va bien, sachant que Bundler chargera les versions correctes de tous mes gems et leurs dépendances. Maintenant, je sais que RVM est idéal pour gérer plusieurs […]

Créer .ruby-version et .ruby-gemset avec rvm

Existe-t-il un moyen de créer les .ruby-version associés .ruby-version et .ruby-gemset lors de la création d’un nouveau gemset? Avec les anciennes versions de rvm, on pouvait faire rvm –create –rvmrc 1.8.7@project , mais cela crée des fichiers .rvmrc . Je pensais lire quelque part, nous pourrions utiliser le commutateur de ligne de commande –ruby-version , […]

Bibliothèque non chargée: /opt/local/lib/libssl.1.0.0.dylib (LoadError)

Je viens juste de découvrir que je ne pouvais plus gem push … et que des fouilles m’avaient obligé à mettre à jour mes certificates SSL RVM. J’ai couru tout le rvm osx-ssl-certs status all mais cela m’a donné: /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require’: dlopen(/Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86_64-darwin12.4.0/openssl.bundle, 9): Library not loaded: /opt/local/lib/libssl.1.0.0.dylib (LoadError) Referenced from: /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/2.0.0/x86_64-darwin12.4.0/openssl.bundle Reason: image not found […]

Nouvelles installations de RVM et Ruby 2.1.1 – dyld library / path path error

J’ai essayé d’installer RVM et Ruby 2.1.1 sur mon nouveau Mac (OS 10.9.2), et tout semble bien se passer jusqu’à ce que j’essaie d’installer une version de Ruby. Mon entrée $ rvm reinstall 2.1 Jusqu’ici tout va bien… ruby-2.1.1 – #removing rubies/ruby-2.1.1.. Searching for binary rubies, this might take some time. Found remote file https://rvm.io/binaries/osx/10.9/x86_64/ruby-2.1.1.tar.bz2 […]

Impossible d’installer Ruby Enterprise Edition avec RVM sur OSX Lion

Voici ce que j’ai fait jusqu’ici. Installation propre d’OS X Lion Téléchargé et installé la dernière version de Xcode sur l’App Store. Git installé Homebrew installé RVM installé J’essaie maintenant d’installer Ruby Enterprise Edition pour un projet avec rvm install ree et de recevoir l’erreur suivante: $ rvm install ree ree-1.8.7-2011.03 – #installing ERROR: Error […]

Erreur lors de l’installation de Nokogiri (1.6.7) sur El Capitan

Un de mes développeurs a mis à jour Nokogiri, et lors de la mise à jour de Gemfile, mon bundle install échoue. ➜ my-project git:(master) bundle install Fetching source index from https://rubygems.org/ Using rake 10.4.2 Using i18n 0.7.0 Using json 1.8.3 Using minitest 5.8.3 Using thread_safe 0.3.5 Using tzinfo 1.2.2 Using activesupport 4.2.3 Using builder […]

Où le bundler stocke-t-il des gemmes?

Je sais que lorsqu’on utilise gem install , la gem sera stockée sous /home/username/.rvm/gems/, sous laquelle gemset sera installé. Mais si j’utilise Bundler et que je spécifie la gemme dans le Gemfile, quand j’exécuterai l’installation groupée, où seront stockées ces gemmes? Et si j’ai déjà installé la gem en utilisant gem install , si je […]

Comment résoudre “/ usr / bin / env: ruby_executable_hooks: Pas de tel fichier ou répertoire”?

Je viens de déployer jekyll dans un vps, et config git après-recevoir le hook dessus. Lorsque je pousse la mise à jour du blog sur vps depuis mon ordinateur portable, je rencontre cette erreur: remote: /usr/bin/env: ruby_executable_hooks: No such file or directory J’ai cherché pendant un moment, et essayé la méthode proposée dans cet article: […]